NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
LOW severity

n8n has a Guardrail Node BypassGHSA-fvfv-ppw4-7h2w

LOWFix: n8n-io/n8n@8d0251d

GHSA-fvfv-ppw4-7h2w is a low-severity (CVSS 3.7) Improper Input Validation vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

Also known asCVE-2026-56349
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fvfv-ppw4-7h2w.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.3%0.5%0.5%0.5%Aug 26Oct 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
80Kdownloads / week

Description

Impact

An end user interacting with a workflow that uses the Guardrail node could craft an input that bypasses the default guardrail instructions.

Patches

The issue has been fixed in n8n version 2.10.0. Users should upgrade to this version or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Limit access to trusted users.
  • Review asses the practical impact of guardrail bypasses in your usecase and adjust your workflow accordingly.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions2.10.0npm install n8n@2.10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 2.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fvfv-ppw4-7h2w is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Impact An end user interacting with a workflow that uses the Guardrail node could craft an input that bypasses the default guardrail instructions. ## Patches The issue has been fixed in n8n version 2.10.0. Users should upgrade to this version or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit access to trusted users. - Review asses the practical impact of guardrail bypasses in your usecase and adjust your workflow accordingly. These workarounds do not fully remediate
O3 Security · Impact-Aware SCA

Is GHSA-fvfv-ppw4-7h2w in your dependencies?

Find it across npm, including transitive dependencies.

n8n has a Guardrail Node Bypass (Low 3.7)