Numpy missing input validationGHSA-frgw-fgh6-9g52
HIGHGHSA-frgw-fgh6-9g52 is a high-severity (CVSS 7.5) CWE-835 vulnerability in numpy. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for numpy — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
numpyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The numpy.pad function in Numpy 1.13.1 and older versions is missing input validation. An empty list or ndarray will stick into an infinite loop, which can allow attackers to cause a DoS attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | numpy | all versions | 1.13.3pip install --upgrade 'numpy==1.13.3' |
Affected Products
numpynumpyResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for numpy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update numpy to 1.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-frgw-fgh6-9g52 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-frgw-fgh6-9g52 in your dependencies?
Find it across PyPI, including transitive dependencies.