NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Magento path traversal vulnerabilityGHSA-fr6f-xmfx-rrpq

MEDIUMFix: magento/magento2@9436781

GHSA-fr6f-xmfx-rrpq is a medium-severity (CVSS 6.5) Path Traversal vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Also known asBIT-magento-2020-9689CVE-2020-9689
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.34%1.90%3.46%5.01%1.2%4.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento versions 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier have a path traversal vulnerability. Successful exploitation could lead to arbitrary code execution.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versions2.3.5-p2composer require magento/community-edition:^2.3.5-p2
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

1 product · 6 configurations
Application
magentomagento
< 2.3.5
1 version
2.3.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.5-p2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fr6f-xmfx-rrpq is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Magento versions 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier have a path traversal vulnerability. Successful exploitation could lead to arbitrary code execution.
O3 Security · Impact-Aware SCA

Is GHSA-fr6f-xmfx-rrpq in your dependencies?

Find it across Packagist, including transitive dependencies.

Magento path traversal vulnerability (Medium 6.5)