PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosureGHSA-fpxp-pfqm-x54w
MEDIUMGHSA-fpxp-pfqm-x54w is a medium-severity (CVSS 4.1) Path Traversal vulnerability in prestashop/ps_checkout. A fix is available for prestashop/ps_checkout — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-fpxp-pfqm-x54w.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
prestashop/ps_checkout🐘prestashop/ps_checkoutReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Missing validation on input vulnerable to directory traversal.
Patches
The problem has been patched in versions:
v4.4.1 for PrestaShop 1.7 (build number: 7.4.4.1) v4.4.1 for PrestaShop 8 (build number: 8.4.4.1) v5.0.5 for PrestaShop 1.7 (build number: 7.5.0.5) v5.0.5 for PrestaShop 8 (build number: 8.5.0.5) v5.0.5 for PrestaShop 9 (build number: 9.5.0.5)
Read the Versioning policy to learn more about the build number.
Credits
Léo CUNÉAZ for reportied this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | prestashop/ps_checkout | all versions | 4.4.1composer require prestashop/ps_checkout:^4.4.1 |
| 🐘Packagist | prestashop/ps_checkout | ≥ 5.0.0&&< 5.0.5 | 5.0.5composer require prestashop/ps_checkout:^5.0.5 |
Affected Products
prestashop checkoutprestashopDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/ps_checkout, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update prestashop/ps_checkout to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fpxp-pfqm-x54w is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-fpxp-pfqm-x54w in your dependencies?
Find it across Packagist, including transitive dependencies.