NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
LOW severity

fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)GHSA-fppq-mj76-fpj2

LOWFix: fluent/fluentd@48e5b85

GHSA-fppq-mj76-fpj2 is a low-severity (CVSS 3.1) Deserialization of Untrusted Data vulnerability in fluentd. EPSS puts its 30-day exploitation probability at 45.0% (99th percentile). A fix is available for fluentd — see the affected versions and patch details below.

Also known asBIT-fluentd-2022-39379CVE-2022-39379
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fppq-mj76-fpj2.

EPSS Exploitation Probability

via FIRST.org ↗
45.0%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%18.9%37.8%56.7%7.7%45.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎fluentd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable FLUENT_OJ_OPTION_MODE is explicitly set to object. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use FLUENT_OJ_OPTION_MODE=object.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsfluentd≥ 1.13.2&&< 1.15.31.15.3bundle update fluentd --conservative

Affected Products

2 products · 2 configurations
OS
fedorafedoraproject
1 version
37
Application
fluentdfluentd
≥ 1.13.2 && < 1.15.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fluentd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fluentd to 1.15.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fppq-mj76-fpj2 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

### Impact A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. ### Patches v1.15.3 ### Workarounds Do not use `FLUENT_OJ_OPTION_MODE=object`. ### References * GHSL-2022-067
O3 Security · Impact-Aware SCA

Is GHSA-fppq-mj76-fpj2 in your dependencies?

Find it across RubyGems, including transitive dependencies.

GHSA-fppq-mj76-fpj2: fluentd RCE — Fixed in 1.15.3