XWiki vulnerable to stored cross-site scripting via any wiki document and the displaycontent/rendercontent templateGHSA-fp7h-f9f5-x4q7
CRITICALFix: xwiki/xwiki-platform@53e8292GHSA-fp7h-f9f5-x4q7 is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in org.xwiki.platform:xwiki-platform-web. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-web — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-fp7h-f9f5-x4q7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-web☕org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-web-templatesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user who can edit a document in a wiki like the user profile can create a stored XSS attack by putting plain HTML code into that document and then tricking another user to visit that document with the displaycontent or rendercontent template and plain output syntax. For example, edit any document with the wiki editor and set the content to <script>alert(1)</script> , save and then append the parameters ?viewer=displaycontent&sheet=&outputSyntax=plain. If this displays an alert, the installation is vulnerable. If a user with programming rights is tricked into visiting such a URL, arbitrary actions be performed with this user's rights, impacting the confidentiality, integrity, and availability of the whole XWiki installation.
Patches
This has been patched in XWiki 14.4.8, 14.10.5 and 15.1RC1 by setting the content type of the response to plain text when the output syntax is not an HTML syntax.
Workarounds
The patch can be manually applied to the rendercontent.vm template in an existing installation to patch this vulnerability without upgrading.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-web | ≥ 2.2.1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-web:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | all versions | 14.4.8org.xwiki.platform:xwiki-platform-web-templates:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 14.5&&< 14.10.5 | 14.10.5org.xwiki.platform:xwiki-platform-web-templates:14.10.5 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 15.0-rc-1&&< 15.1-rc-1 | 15.1-rc-1org.xwiki.platform:xwiki-platform-web-templates:15.1-rc-1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-web to 14.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fp7h-f9f5-x4q7 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-fp7h-f9f5-x4q7 in your dependencies?
Find it across Maven, including transitive dependencies.