NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Moodle allows attackers to discover hidden course namesGHSA-fmq9-58q4-xjw5

MEDIUMFix: moodle/moodle@214950d

GHSA-fmq9-58q4-xjw5 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asCVE-2016-2154
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.73%1.46%2.19%0.3%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to discover hidden course names by subscribing to a rule.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.8.0&&< 2.8.112.8.11composer require moodle/moodle:^2.8.11
🐘Packagistmoodle/moodle≥ 2.9.0&&< 2.9.52.9.5composer require moodle/moodle:^2.9.5
🐘Packagistmoodle/moodle≥ 3.0.0&&< 3.0.33.0.3composer require moodle/moodle:^3.0.3

Affected Products

1 product · 19 configurations
Application
moodlemoodle
19 versions
2.8.02.8.12.8.22.8.32.8.42.8.52.8.62.8.72.8.82.8.92.8.102.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.8.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fmq9-58q4-xjw5 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to discover hidden course names by subscribing to a rule.
O3 Security · Impact-Aware SCA

Is GHSA-fmq9-58q4-xjw5 in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle allows attackers to discover hidden course names