GHSA-fm4g-76c9-7w69 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.http4s:http4s-ember-server_2.12. A fix is available for org.http4s:http4s-ember-server_2.12 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-fm4g-76c9-7w69.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
GHSA-fm4g-76c9-7w69 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 398,142 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
org.http4s:http4s-ember-server_2.12☕org.http4s:http4s-ember-server_2.13☕org.http4s:http4s-ember-server_3☕org.http4s:http4s-ember-server_2.13☕org.http4s:http4s-ember-server_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The DigestAuth server middleware's stale-nonce cleanup uses an inverted comparison: it removes fresh nonces and stops at the first stale one. Because a new nonce is created for every unauthenticated challenge, an attacker can drive the nonce map to grow without bound until the JVM runs out of heap.
Impact
Unauthenticated remote denial of service (gradual heap exhaustion / OOM) against any service using DigestAuth. The leak is persistent.
Preconditions
- Application uses
DigestAuthon at least one route.
Workarounds
- Front the DigestAuth protected routes with a rate limiter to slow the leak.
- Restart periodically.
Fixes
- The eviction logic is corrected.
- A max cache size of 1000000 is imposed to protected against a burst between evictions. This limit is not yet configurable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-ember-server_2.12 | all versions | 0.23.35org.http4s:http4s-ember-server_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-server_2.13 | all versions | 0.23.35org.http4s:http4s-ember-server_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-server_3 | all versions | 0.23.35org.http4s:http4s-ember-server_3:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-server_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-server_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-ember-server_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-server_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-ember-server_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-ember-server_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fm4g-76c9-7w69 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-fm4g-76c9-7w69 in your dependencies?
Find it across Maven, including transitive dependencies.