Insertion of Sensitive Information into Log File in typo3/cms-coreGHSA-fh99-4pgr-8j99
MEDIUMFix: TYPO3/typo3@c93ea69GHSA-fh99-4pgr-8j99 is a medium-severity (CVSS 5.3) CWE-532 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-fh99-4pgr-8j99.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Meta
- CVSS:
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N/E:F/RL:O/RC:C(4.9)
Problem
It has been discovered that system internal credentials or keys (e.g. database credentials) have been logged as plaintext in exception handlers, when logging the complete exception stack trace.
Solution
Update to TYPO3 versions 7.6.57 ELTS, 8.7.47 ELTS, 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above.
Credits
Thanks to Marco Huber who reported this issue and to TYPO3 security member Torben Hansen who fixed the issue.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 7.0.0&&< 7.6.57 | 7.6.57composer require typo3/cms-core:^7.6.57 |
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.47 | 8.7.47composer require typo3/cms-core:^8.7.47 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.35 | 9.5.35composer require typo3/cms-core:^9.5.35 |
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.29 | 10.4.29composer require typo3/cms-core:^10.4.29 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.11 | 11.5.11composer require typo3/cms-core:^11.5.11 |
| 🐘Packagist | typo3/cms | ≥ 10.0.0&&< 10.4.29 | 10.4.29composer require typo3/cms:^10.4.29 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 7.6.57 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fh99-4pgr-8j99 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-fh99-4pgr-8j99 in your dependencies?
Find it across Packagist, including transitive dependencies.