NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Bloom Uncontrolled Search Path Element vulnerabilityGHSA-fgwp-pwqq-g3w4

HIGHFix: bits-and-blooms/bloom@658f139

GHSA-fgwp-pwqq-g3w4 is a high-severity (CVSS 7.8) CWE-427 vulnerability in github.com/bits-and-blooms/bloom. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/bits-and-blooms/bloom — see the affected versions and patch details below.

Also known asCVE-2023-0247
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fgwp-pwqq-g3w4.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs36th percentile — riskier than 36% of all scored CVEsHighest risk
0.00%0.30%0.61%0.91%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/bits-and-blooms/bloom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Uncontrolled Search Path Element in GitHub repository bits-and-blooms/bloom prior to 3.3.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/bits-and-blooms/bloomall versions3.3.1go get github.com/bits-and-blooms/bloom@v3.3.1

Affected Products

1 product · 1 configurations
Application
bloombloom_project
< 3.3.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/bits-and-blooms/bloom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/bits-and-blooms/bloom to 3.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fgwp-pwqq-g3w4 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Uncontrolled Search Path Element in GitHub repository bits-and-blooms/bloom prior to 3.3.1.
O3 Security · Impact-Aware SCA

Is GHSA-fgwp-pwqq-g3w4 in your dependencies?

Find it across Go, including transitive dependencies.

Bloom Uncontrolled Search Path Element vulnerability