NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

OpenClaw plugin runtime command execution is part of trusted plugin boundaryGHSA-ff98-w8hj-qrxf

Fix: openclaw/openclaw@2e421f3

GHSA-ff98-w8hj-qrxf is a security vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Mar 4, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

133other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.4Mdownloads / week

Description

Summary

OpenClaw plugins/extensions run in-process and are treated as trusted code. This advisory tracks trust-boundary clarification around plugin runtime command execution (runtime.system.runCommandWithTimeout).

Impact

Plugins already execute with the same OS privileges as the OpenClaw process. Exposing runtime command helpers does not cross an additional sandbox boundary.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Latest published version reviewed: 2026.2.17
  • Affected range for this advisory record: <= 2026.2.17
  • Planned patched version metadata: 2026.2.19 (next release line)

Fix Commit(s)

  • 2e421f32dfc589c02706265fd3c3137ffc06c4b1

Remediation

  • Install only trusted plugins.
  • Use plugins.allow to pin explicit trusted plugin IDs.
  • SECURITY.md now explicitly documents that plugin runtime helpers are convenience APIs, not a sandbox boundary.

OpenClaw thanks @markmusson for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclawall versions2026.2.19npm install openclaw@2026.2.19

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ff98-w8hj-qrxf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary OpenClaw plugins/extensions run in-process and are treated as trusted code. This advisory tracks trust-boundary clarification around plugin runtime command execution (`runtime.system.runCommandWithTimeout`). ### Impact Plugins already execute with the same OS privileges as the OpenClaw process. Exposing runtime command helpers does not cross an additional sandbox boundary. ### Affected Packages / Versions - Package: `openclaw` (npm) - Latest published version reviewed: `2026.2.17` - Affected range for this advisory record: `<= 2026.2.17` - Planned patched version metadata: `2026.
O3 Security · Impact-Aware SCA

Is GHSA-ff98-w8hj-qrxf in your dependencies?

Find it across npm, including transitive dependencies.

OpenClaw plugin runtime command execution is part of…