GHSA-f9q6-69fh-4w5w is a high-severity (CVSS 7.4) Open Redirect vulnerability in flask-oidc. A fix is available for flask-oidc — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
flask-oidcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
flask-oidc version 0.1.2 and earlier is vulnerable to an open redirect.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | flask-oidc | all versions | 1.0.0pip install --upgrade 'flask-oidc==1.0.0' |
Affected Products
flask-oidcflask-oidc_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flask-oidc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update flask-oidc to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f9q6-69fh-4w5w is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is GHSA-f9q6-69fh-4w5w in your dependencies?
Find it across PyPI, including transitive dependencies.