Unsanitized user controlled input in module generationGHSA-f8pq-3926-8gx5
HIGHFix: open-telemetry/opentelemetry-js@ffe641cGHSA-f8pq-3926-8gx5 is a high-severity (CVSS 8.1) remote code execution vulnerability in @opentelemetry/instrumentation. A fix is available for @opentelemetry/instrumentation — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@opentelemetry/instrumentationnpmDescription
Impact
The import-in-the-middle loader used by @opentelemetry/instrumentation works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function.
Patches
This vulnerability has been patched in @opentelemetry/instrumentation version 0.41.2
Workarounds
- Do not pass any user-supplied input to
import(). Instead, verify it against a set of allowed values. - If using
@opentelemetry/instrumentationwith support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or theNODE_OPTIONSenvironment variable):
--experimental-loader=@opentelemetry/instrumentation/hook.mjs
--experimental-loader @opentelemetry/instrumentation/hook.mjs
--loader=import-in-the-middle/hook.mjs
--loader import-in-the-middle/hook.mjs
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @opentelemetry/instrumentation | ≥ 0.40.0&&< 0.41.2 | 0.41.2npm install @opentelemetry/instrumentation@0.41.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @opentelemetry/instrumentation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @opentelemetry/instrumentation to 0.41.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f8pq-3926-8gx5 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-f8pq-3926-8gx5 in your dependencies?
Find it across npm, including transitive dependencies.