NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Weblate: SSRF via the webhook add-on using unprotected fetch_url()GHSA-f8hv-g549-hwg2

MEDIUMFix: WeblateOrg/weblate#18815

GHSA-f8hv-g549-hwg2 is a medium-severity (CVSS 4.1) Server-Side Request Forgery (SSRF) vulnerability in weblate. A fix is available for weblate — see the affected versions and patch details below.

Also known asCVE-2026-39845PYSEC-2026-156
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f8hv-g549-hwg2.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍weblate

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Weblate is a web based localization tool. In versions prior to 5.17, the webhook add-on did not utilize existing SSRF protections. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can disable the webhook add-on as a workaround.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIweblateall versions5.17pip install --upgrade 'weblate==5.17'

Affected Products

1 product · 1 configurations
Application
weblateweblate
< 5.17
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for weblate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update weblate to 5.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f8hv-g549-hwg2 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact The webhook add-on did not utilize existing SSRF protection. ### Patches * https://github.com/WeblateOrg/weblate/pull/18815 ### Workarounds Disabling the add-on would avoid misusing this. ### References Thanks to @Lihfdgjr for reporting this via GitHub.
O3 Security · Impact-Aware SCA

Is GHSA-f8hv-g549-hwg2 in your dependencies?

Find it across PyPI, including transitive dependencies.

Weblate: SSRF via the webhook add-on using…