CefSharp affected by incorrect handle provided in unspecified circumstances in Mojo on WindowsGHSA-f87w-3j5w-v58p
HIGHGHSA-f87w-3j5w-v58p is a high-severity (CVSS 8.3) vulnerability in CefSharp.Wpf. A fix is available for CefSharp.Wpf — see the affected versions and patch details below.
Real-World Exposure
CefSharp.Wpf.NETCefSharp.Wpf.HwndHost.NETCefSharp.Wpf.NetCore.NETCefSharp.WinForms.NETCefSharp.WinForms.NetCore.NETCefSharp.OffScreen.NetCore.NETCefSharp.OffScreenReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect handle provided in unspecified circumstances in Mojo in Google Chrome on Windows prior to 134.0.6998.177 allowed a remote attacker to perform a sandbox escape via a malicious file. (Chromium security severity: High)
https://nvd.nist.gov/vuln/detail/CVE-2025-2783 https://chromereleases.googleblog.com/2025/03/stable-channel-update-for-desktop_25.html https://issues.chromium.org/issues/405143032
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | CefSharp.Wpf | all versions | 134.3.90dotnet add package CefSharp.Wpf --version 134.3.90 |
| .NETNuGet | CefSharp.Wpf.HwndHost | all versions | 134.3.90dotnet add package CefSharp.Wpf.HwndHost --version 134.3.90 |
| .NETNuGet | CefSharp.Wpf.NetCore | all versions | 134.3.90dotnet add package CefSharp.Wpf.NetCore --version 134.3.90 |
| .NETNuGet | CefSharp.WinForms | all versions | 134.3.90dotnet add package CefSharp.WinForms --version 134.3.90 |
| .NETNuGet | CefSharp.WinForms.NetCore | all versions | 134.3.90dotnet add package CefSharp.WinForms.NetCore --version 134.3.90 |
| .NETNuGet | CefSharp.OffScreen.NetCore | all versions | 134.3.90dotnet add package CefSharp.OffScreen.NetCore --version 134.3.90 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for CefSharp.Wpf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update CefSharp.Wpf to 134.3.90 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f87w-3j5w-v58p is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-f87w-3j5w-v58p in your dependencies?
Find it across NuGet, including transitive dependencies.