NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Django Incorrectly Validates URLsGHSA-f7cm-ccfp-3q4r

HIGHFix: django/django@45ac9d4

GHSA-f7cm-ccfp-3q4r is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Also known asCVE-2014-0480PYSEC-2014-4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.03%0.96%1.89%2.82%0.6%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The core.urlresolvers.reverse function in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 does not properly validate URLs, which allows remote attackers to conduct phishing attacks via a // (slash slash) in a URL, which triggers a scheme-relative URL to be generated.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.14pip install --upgrade 'django==1.4.14'
🐍PyPIdjango≥ 1.5&&< 1.5.91.5.9pip install --upgrade 'django==1.5.9'
🐍PyPIdjango≥ 1.6&&< 1.6.61.6.6pip install --upgrade 'django==1.6.6'

Affected Products

2 products · 42 configurations
Application
djangodjangoproject
≤ 1.4.13
28 versions
1.41.4.11.4.21.4.41.4.51.4.61.4.71.4.81.4.91.4.101.4.111.4.12
OS
opensuseopensuse
2 versions
12.313.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f7cm-ccfp-3q4r is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The `core.urlresolvers.reverse` function in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 does not properly validate URLs, which allows remote attackers to conduct phishing attacks via a `//` (slash slash) in a URL, which triggers a scheme-relative URL to be generated.
O3 Security · Impact-Aware SCA

Is GHSA-f7cm-ccfp-3q4r in your dependencies?

Find it across PyPI, including transitive dependencies.

Django Incorrectly Validates URLs (High 7.5)