Magento Cross-Site Request Forgery (CSRF)GHSA-f6ww-vqw2-xp3v
MEDIUMGHSA-f6ww-vqw2-xp3v is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site request forgery vulnerability in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 can cause unwanted items to be added to a shopper's cart due to an insufficiently robust anti-CSRF token implementation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.2.0&&< 2.2.9 | 2.2.9composer require magento/community-edition:^2.2.9 |
| 🐘Packagist | magento/community-edition | ≥ 2.1.0&&< 2.1.18 | 2.1.18composer require magento/community-edition:^2.1.18 |
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.2 | 2.3.2composer require magento/community-edition:^2.3.2 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f6ww-vqw2-xp3v is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-f6ww-vqw2-xp3v in your dependencies?
Find it across Packagist, including transitive dependencies.