OpenClaw: Media Parsing Path Traversal Leads to Arbitrary File ReadGHSA-f6pf-4gjx-c94r
Fix: openclaw/openclaw@4797bbcGHSA-f6pf-4gjx-c94r is a Path Traversal vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for GHSA-f6pf-4gjx-c94r.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
OpenClaw <= 2026.3.24 Media Parsing Path Traversal to Arbitrary File Read
Affected Packages / Versions
- Package:
openclaw(npm) - Latest published npm version:
2026.3.31 - Vulnerable version range:
<=2026.3.24 - Patched versions:
>= 2026.3.28 - First stable tag containing the fix:
v2026.3.28
Fix Commit(s)
4797bbc5b96e2cca5532e43b58915c051746fe37— 2026-03-25T13:35:16-06:00
Release Process Note
- The fix is already present in released version
2026.3.28.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.3.28npm install openclaw@2026.3.28 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f6pf-4gjx-c94r is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-f6pf-4gjx-c94r in your dependencies?
Find it across npm, including transitive dependencies.