GHSA-f6f8-9mx6-9mx2 is a high-severity (CVSS 7.5) CWE-130 vulnerability in django. EPSS puts its 30-day exploitation probability at 28.6% (98th percentile). A fix is available for django — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-f6f8-9mx6-9mx2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 5.0&&< 5.0.7 | 5.0.7pip install --upgrade 'django==5.0.7' |
| 🐍PyPI | django | ≥ 4.2&&< 4.2.14 | 4.2.14pip install --upgrade 'django==4.2.14' |
Affected Products
djangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 5.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f6f8-9mx6-9mx2 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | ansible-automation-platform-24/lightspeed-rhel8:1.0.2-10 | RHBA-2024:6429 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | automation-controller-0:4.5.10-1.el8ap | RHSA-2024:6428 |
| Red Hat OpenStack Services on OpenShift 18.0 | python-django-0:3.2.12-8.el9ost | RHSA-2024:9481 |
| Red Hat Satellite 6.16 for RHEL 8 | python-django-0:4.2.16-1.el8pc | RHSA-2024:8906 |
| RHUI 4 for RHEL 8 | python-django-0:4.2.15-1.el8ui | RHSA-2025:1335 |
Frequently Asked Questions
Is GHSA-f6f8-9mx6-9mx2 in your dependencies?
Find it across PyPI, including transitive dependencies.