NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Jenkins OpenTelemetry Plugin missing permission check allows capturing credentialsGHSA-f696-867g-2759

MEDIUMFix: jenkinsci/opentelemetry-plugin@f5a4ec1

GHSA-f696-867g-2759 is a medium-severity (CVSS 4.2) CWE-862 vulnerability in io.jenkins.plugins:opentelemetry. A fix is available for io.jenkins.plugins:opentelemetry — see the affected versions and patch details below.

Also known asCVE-2025-58460
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f696-867g-2759.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.0%0.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.jenkins.plugins:opentelemetry

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A missing permission check in Jenkins OpenTelemetry Plugin 3.1543.v8446b_92b_cd64 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.jenkins.plugins:opentelemetryall versions3.1543.1545.vf5aio.jenkins.plugins:opentelemetry:3.1543.1545.vf5a

Affected Products

1 product · 1 configurations
Application
opentelemetryjenkins
< 3.1543.1545.vf5a_4ec123769
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jenkins.plugins:opentelemetry, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.jenkins.plugins:opentelemetry to 3.1543.1545.vf5a or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f696-867g-2759 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A missing permission check in Jenkins OpenTelemetry Plugin 3.1543.v8446b_92b_cd64 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
O3 Security · Impact-Aware SCA

Is GHSA-f696-867g-2759 in your dependencies?

Find it across Maven, including transitive dependencies.

Jenkins OpenTelemetry Plugin missing permission check…