Adyen APIs Library for Python timing attack vulnerabilityGHSA-f3q4-ggfp-jv34
MEDIUMFix: Adyen/adyen-python-api-library#170GHSA-f3q4-ggfp-jv34 is a medium-severity (CVSS 5.3) vulnerability in adyen. A fix is available for adyen — see the affected versions and patch details below.
Real-World Exposure
adyenReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Adyen has utility methods for validating notification HMAC signatures. The is_valid_hmac and is_valid_hmac_notification methods are vulnerable to a timing attack, you should compare the hash of the HMACs instead.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | adyen | ≥ 2.2.0&&< 7.1.0 | 7.1.0pip install --upgrade 'adyen==7.1.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for adyen, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update adyen to 7.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f3q4-ggfp-jv34 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-f3q4-ggfp-jv34 in your dependencies?
Find it across PyPI, including transitive dependencies.