NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP ConfigurationsGHSA-f3gh-529w-v32x

CRITICALFix: zitadel/zitadel@d9d8339

GHSA-f3gh-529w-v32x is a critical-severity (CVSS 9) CWE-639 vulnerability in github.com/zitadel/zitadel/v2. A fix is available for github.com/zitadel/zitadel/v2 — see the affected versions and patch details below.

Also known asCVE-2025-27507GO-2025-3499
Published
Updated
Affected
16 pkgs
Patched
16 / 16
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f3gh-529w-v32x.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

16 pkgs affected
🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2🐹github.com/zitadel/zitadel/v2+8 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

ZITADEL's Admin API contains Insecure Direct Object Reference (IDOR) vulnerabilities that allow authenticated users, without specific IAM roles, to modify sensitive settings. While several endpoints are affected, the most critical vulnerability lies in the ability to manipulate LDAP configurations. Customers who do not utilize LDAP for authentication are not at risk from the most severe aspects of this vulnerability. However, we still strongly recommend upgrading to the patched version to address all identified issues.

Description

ZITADEL's Admin API, intended for managing ZITADEL instances, contains 12 HTTP endpoints that are unexpectedly accessible to authenticated ZITADEL users who are not ZITADEL managers. The most critical vulnerable endpoints relate to LDAP configuration:

  • /idps/ldap
  • /idps/ldap/{id}

By accessing these endpoints, unauthorized users could:

  • Modify ZITADEL's instance LDAP settings, redirecting all LDAP login attempts to a malicious server, effectively taking over user accounts.
  • Expose the original LDAP server's password, potentially compromising all user accounts.

Additional Vulnerable Endpoints

The following endpoints are also affected by IDOR vulnerabilities, potentially allowing unauthorized modification of instance settings such as languages, labels, and templates:

  • /idps/templates/_search
  • /idps/templates/{id}
  • /policies/label/_activate
  • /policies/label/logo
  • /policies/label/logo_dark
  • /policies/label/icon
  • /policies/label/icon_dark
  • /policies/label/font
  • /text/message/passwordless_registration/{language}
  • /text/login/{language}

Impact

The impact of this vulnerability varies depending on whether a ZITADEL instance utilizes LDAP for authentication:

  • LDAP Users: Successful exploitation could lead to complete takeover of user accounts and exposure of the LDAP server's password.
  • Non-LDAP Users: While the most severe risks are related to LDAP, exploitation of the additional vulnerable endpoints could still allow unauthorized modification of instance settings, impacting all organizations.

Patches

2.x versions are fixed on >= 2.71.0 2.70.x versions are fixed on >= 2.70.1 2.69.x versions are fixed on >= 2.69.4 2.68.x versions are fixed on >= 2.68.4 2.67.x versions are fixed on >= 2.67.8 2.66.x versions are fixed on >= 2.66.11 2.65.x versions are fixed on >= 2.65.6 2.64.x versions are fixed on >= 2.64.5 2.63.x versions are fixed on >= 2.63.8

Questions

If you have any questions or comments about this advisory, please email us at [email protected]

Credit

This vulnerability was discovered by Amit Laish, a senior security researcher from GE Vernova and we want to thank him for reporting this to us!

Affected Packages

16 total 16 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/zitadel/zitadel/v2all versions2.63.8go get github.com/zitadel/zitadel/v2@v2.63.8
🐹Gogithub.com/zitadel/zitadel/v2≥ 2.64.0&&< 2.64.52.64.5go get github.com/zitadel/zitadel/v2@v2.64.5
🐹Gogithub.com/zitadel/zitadel/v2≥ 2.65.0&&< 2.65.62.65.6go get github.com/zitadel/zitadel/v2@v2.65.6
🐹Gogithub.com/zitadel/zitadel/v2≥ 2.66.0&&< 2.66.112.66.11go get github.com/zitadel/zitadel/v2@v2.66.11
🐹Gogithub.com/zitadel/zitadel/v2≥ 2.67.0&&< 2.67.82.67.8go get github.com/zitadel/zitadel/v2@v2.67.8
🐹Gogithub.com/zitadel/zitadel/v2≥ 2.68.0&&< 2.68.42.68.4go get github.com/zitadel/zitadel/v2@v2.68.4

Affected Products

1 product · 8 configurations
Application
zitadelzitadel
≥ 2.70.0 && < 2.70.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zitadel/zitadel/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/zitadel/zitadel/v2 to 2.63.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f3gh-529w-v32x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary ZITADEL's Admin API contains Insecure Direct Object Reference (IDOR) vulnerabilities that allow authenticated users, without specific IAM roles, to modify sensitive settings. While several endpoints are affected, the most critical vulnerability lies in the ability to manipulate LDAP configurations. Customers who do not utilize LDAP for authentication are not at risk from the most severe aspects of this vulnerability. However, we still strongly recommend upgrading to the patched version to address all identified issues. ### Description ZITADEL's Admin API, intended for managing Z
O3 Security · Impact-Aware SCA

Is GHSA-f3gh-529w-v32x in your dependencies?

Find it across Go, including transitive dependencies.

IDOR Vulnerabilities in ZITADEL's Admin API that…