Moodle External function mod_assign_save_submission does not check due datesGHSA-cw72-69wq-f9f2
MEDIUMFix: moodle/moodle@0766509GHSA-cw72-69wq-f9f2 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The save_submission function in mod/assign/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote authenticated users to bypass intended due-date restrictions by leveraging the student role for a web-service request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 2.7&&< 2.7.13 | 2.7.13composer require moodle/moodle:^2.7.13 |
| 🐘Packagist | moodle/moodle | ≥ 2.8&&< 2.8.11 | 2.8.11composer require moodle/moodle:^2.8.11 |
| 🐘Packagist | moodle/moodle | ≥ 2.9&&< 2.9.5 | 2.9.5composer require moodle/moodle:^2.9.5 |
| 🐘Packagist | moodle/moodle | ≥ 3.0&&< 3.0.3 | 3.0.3composer require moodle/moodle:^3.0.3 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.7.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cw72-69wq-f9f2 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-cw72-69wq-f9f2 in your dependencies?
Find it across Packagist, including transitive dependencies.