Craft CMS Arbitrary System File ReadGHSA-cw6g-qmjq-6w2w
HIGHGHSA-cw6g-qmjq-6w2w is a high-severity (CVSS 7.7) Path Traversal vulnerability in craftcms/cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for craftcms/cms — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cw6g-qmjq-6w2w.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
craftcms/cms🐘craftcms/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
By abusing the mail notification template it is possible to read arbitrary operating system files.
Details
The dataUrl function can be exploited if an attacker has write permissions on system notification templates. This function accepts an absolute file path, reads the file's content, and converts it into a Base64-encoded string. By embedding this function within a system notification template, the attacker can exfiltrate the Base64-encoded file content through a triggered system email notification. Once the email is received, the Base64 payload can be decoded, allowing the attacker to read arbitrary files on the server.
Requirements:
- write permissions to system notification templates
- ability to trigger a corresponding system email
PoC
- Modify a template to contain the following twig template string:
{{ dataUrl('/var/www/web/.env') }}
- Trigger the corresponding notification email (e.g. by resetting a password)
- Receive the email and decode the base64 string
Mail received:
Decoded string:
Impact
-
Exposure of Sensitive Information: Arbitrary file read can lead to the exposure of sensitive data such as configuration files (e.g., /etc/passwd, .env, config.php), which may contain credentials, API keys, or database passwords. This can provide the attacker with further access to the system or connected services.
-
Privilege Escalation: If the attacker is able to read files that contain privileged information, such as credentials for other systems or applications, they may be able to escalate their privileges beyond what the web admin role originally allowed, potentially gaining full control over the server or other related systems.
-
Server Compromise: Access to files like SSH keys, private certificates, or system configuration files can lead to the complete compromise of the underlying server. With this information, an attacker could remotely log in to the server or impersonate it in secure communications.
-
Exfiltration of User Data: The ability to read arbitrary files may allow an attacker to access user data, such as stored passwords, session tokens, or private information (like uploaded files or logs), leading to a breach of confidentiality and violating privacy regulations (e.g., GDPR).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/cms | ≥ 5.0.0-alpha.1&&< 5.4.9 | 5.4.9composer require craftcms/cms:^5.4.9 |
| 🐘Packagist | craftcms/cms | ≥ 3.5.13&&< 4.12.8 | 4.12.8composer require craftcms/cms:^4.12.8 |
Affected Products
craft cmscraftcmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/cms to 5.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cw6g-qmjq-6w2w is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-cw6g-qmjq-6w2w in your dependencies?
Find it across Packagist, including transitive dependencies.