NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

Moodle allows teachers to evade trusttext config when restoring glossary entriesGHSA-cw24-f6fq-7j9v

LOW

GHSA-cw24-f6fq-7j9v is a low-severity (CVSS 3.1) CWE-863 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2025-26532CVE-2025-26532
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cw24-f6fq-7j9v.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs19th percentile — riskier than 19% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.3%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.5.0-beta&&< 4.5.24.5.2composer require moodle/moodle:^4.5.2
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.64.4.6composer require moodle/moodle:^4.4.6
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.104.3.10composer require moodle/moodle:^4.3.10
🐘Packagistmoodle/moodleall versions4.1.16composer require moodle/moodle:^4.1.16

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 4.5.0 && < 4.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cw24-f6fq-7j9v is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored.
O3 Security · Impact-Aware SCA

Is GHSA-cw24-f6fq-7j9v in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle allows teachers to evade trusttext config when…