NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

TYPO3 CMS exposes sensitive information in an error messageGHSA-cvm2-5f78-g9m8

Fix: TYPO3-CMS/core@e1e4380

GHSA-cvm2-5f78-g9m8 is a CWE-209 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Also known asCVE-2025-59016
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cvm2-5f78-g9m8.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.25%0.49%0.73%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Error messages containing sensitive information in the File Abstraction Layer in TYPO3 CMS versions 9.0.0-9.5.54, 10.0.0-10.4.53, 11.0.0-11.5.47, 12.0.0-12.4.36, and 13.0.0-13.4.17 allow backend users to disclose full file paths via failed low-level file-system operations.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 12.4.3712.4.37composer require typo3/cms-core:^12.4.37
🐘Packagisttypo3/cms-core≥ 10.0.0&&< 12.4.3712.4.37composer require typo3/cms-core:^12.4.37
🐘Packagisttypo3/cms-core≥ 11.0.0&&< 12.4.3712.4.37composer require typo3/cms-core:^12.4.37
🐘Packagisttypo3/cms-core≥ 12.0.0&&< 12.4.3712.4.37composer require typo3/cms-core:^12.4.37
🐘Packagisttypo3/cms-core≥ 13.0.0&&< 13.4.1813.4.18composer require typo3/cms-core:^13.4.18

Affected Products

1 product · 5 configurations
Application
typo3typo3
≥ 13.0.0 && ≤ 13.4.18
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 12.4.37 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cvm2-5f78-g9m8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Error messages containing sensitive information in the File Abstraction Layer in TYPO3 CMS versions 9.0.0-9.5.54, 10.0.0-10.4.53, 11.0.0-11.5.47, 12.0.0-12.4.36, and 13.0.0-13.4.17 allow backend users to disclose full file paths via failed low-level file-system operations.
O3 Security · Impact-Aware SCA

Is GHSA-cvm2-5f78-g9m8 in your dependencies?

Find it across Packagist, including transitive dependencies.

TYPO3 CMS exposes sensitive information in an error…