Magento Open Source Security Advisory: Patch SUPEE-10975GHSA-cv25-3pxr-4q7x
GHSA-cv25-3pxr-4q7x is a remote code execution vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Real-World Exposure
magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento Commerce 1.14.4.0 and Open Source 1.9.4.0 have been enhanced with critical security updates to address multiple vulnerabilities, including remote code execution (RCE), cross-site scripting (XSS), cross-site request forgery (CSRF), and more. The following issues have been identified and remediated:
- PRODSECBUG-1589: Stops Brute Force Requests via basic RSS authentication
- MAG-23: M1 Credit Card Storage Capability
- PRODSECBUG-2149: Authenticated RCE using customer import
- PRODSECBUG-2159: API Based RCE Vulnerability
- PRODSECBUG-2156: RCE Via Unauthorized Upload
- PRODSECBUG-2155: Authenticated RCE using dataflow
- PRODSECBUG-2053: Prevents XSS in Newsletter Template
- PRODSECBUG-2142: XSS in CMS Preview
- PRODSECBUG-1860: Admin Account XSS Attack Cessation via Filename
- PRODSECBUG-2119: EE Patch to include names in templates
- PRODSECBUG-2129: XSS in Google Analytics Vulnerability
- PRODSECBUG-2019: Merchant Wishlist Security Strengthening
- PRODSECBUG-2104: Send to a Friend Vulnerability
- PRODSECBUG-2125: CSRF on deletion of Blocks Vulnerability
- PRODSECBUG-2088: CSRF Vulnerability related to Customer Group Deletion
- PRODSECBUG-2140: CSRF on deletion of Site Map
- PRODSECBUG-2108: Outdated jQuery causing PCI scanning failures
- MAG-12, MAG-2: Encryption Keys Stored in Plain Text
- PRODSECBUG-2141: Unauthorized Admin Panel Bypass
Patching and Upgrading:
Patches and upgrades are available for the following Magento versions:
Magento Commerce 1.9.0.0-1.14.4.0: Apply SUPEE-10975 or upgrade to Magento Commerce 1.14.4.0. Magento Open Source 1.5.0.0-1.9.4.0: Apply SUPEE-10975 or upgrade to Magento Open Source 1.9.4.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 1.9.0.0&&< 1.14.4.0 | 1.14.4.0composer require magento/community-edition:^1.14.4.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 1.14.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cv25-3pxr-4q7x is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-cv25-3pxr-4q7x in your dependencies?
Find it across Packagist, including transitive dependencies.