Rand is unsound with a custom logger using rand::rng()GHSA-cq8v-f236-94qc
Fix: rust-random/rand#1763GHSA-cq8v-f236-94qc is a security vulnerability in rand. A fix is available for rand — see the affected versions and patch details below.
Real-World Exposure
rand🦀rand🦀randReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
It has been reported (by @lopopolo) that the rand library is unsound (i.e. that safe code using the public API can cause Undefined Behaviour) when all the following conditions are met:
- The
logandthread_rngfeatures are enabled - A custom logger is defined
- The custom logger accesses
rand::rng()(previouslyrand::thread_rng()) and calls anyTryRng(previouslyRngCore) methods onThreadRng - The
ThreadRng(attempts to) reseed while called from the custom logger (this happens every 64 kB of generated data) - Trace-level logging is enabled or warn-level logging is enabled and the random source (the
getrandomcrate) is unable to provide a new seed
TryRng (previously RngCore) methods for ThreadRng use unsafe code to cast *mut BlockRng<ReseedingCore> to &mut BlockRng<ReseedingCore>. When all the above conditions are met this results in an aliased mutable reference, violating the Stacked Borrows rules. Miri is able to detect this violation in sample code. Since construction of aliased mutable references is Undefined Behaviour, the behaviour of optimized builds is hard to predict.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | rand | ≥ 0.9.0&&< 0.9.3 | 0.9.3cargo update -p rand --precise 0.9.3 |
| 🦀crates.io | rand | ≥ 0.10.0&&< 0.10.1 | 0.10.1cargo update -p rand --precise 0.10.1 |
| 🦀crates.io | rand | ≥ 0.7.0&&< 0.8.6 | 0.8.6cargo update -p rand --precise 0.8.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rand, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rand to 0.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cq8v-f236-94qc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-cq8v-f236-94qc in your dependencies?
Find it across crates.io, including transitive dependencies.