Orchid Platform has Method Exposure Vulnerability in ModalsGHSA-cm46-gqf4-mv4f
MEDIUMGHSA-cm46-gqf4-mv4f is a medium-severity (CVSS 4.1) CWE-749 vulnerability in orchid/platform. A fix is available for orchid/platform — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cm46-gqf4-mv4f.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
orchid/platformReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This vulnerability is a method exposure issue (CWE-749: Exposed Dangerous Method or Function) in the Orchid Platform’s asynchronous modal functionality, affecting users of Orchid Platform version 8 through 14.42.x. Attackers could exploit this vulnerability to call arbitrary methods within the Screen class, leading to potential brute force of database tables, validation checks against user credentials, and disclosure of the server’s real IP address.
Patches
The issue has been patched in the latest release, version 14.43.0, released on November 6, 2024. Users should upgrade to version 14.43.0 or later to address this vulnerability.
Workarounds
If upgrading to version 14.43.0 is not immediately possible, you can mitigate the vulnerability by implementing middleware to intercept and validate requests to asynchronous modal endpoints, allowing only approved methods and parameters.
Example middleware:
namespace App\Http\Middleware;
use Closure;
use Illuminate\Http\Request;
use Symfony\Component\HttpFoundation\Response;
class PreventBruteForceOnAsyncRoute
{
/**
* Methods that are restricted from being invoked via the async route.
*/
protected array $restrictedMethods = [
'validate',
'handle',
'__invoke',
'validateWith',
'validateWithBag',
'callAction',
];
/**
* Handle an incoming request.
*/
public function handle(Request $request, Closure $next): Response
{
// Retrieve the current route from the request.
/** @var \Illuminate\Routing\Route|null $route */
$route = $request->route();
// Allow requests to routes other than "platform.async".
if ($route?->getName() !== 'platform.async') {
return $next($request);
}
// Block requests attempting to invoke any of the restricted methods.
if (in_array($route->parameter('method'), $this->restrictedMethods)) {
abort(503, sprintf(
'Access to the "%s" method is restricted.',
$route->parameter('method')
));
}
// Continue request processing for other cases.
return $next($request);
}
}
References
Acknowledgements
We would like to extend our sincere gratitude to Positive Technologies and researcher Vladislav Gladky for identifying the vulnerability and their significant contribution to enhancing the security of our platform. Their expertise and dedication play a crucial role in making Orchid more reliable and secure for all users.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | orchid/platform | ≥ 8.0&&< 14.43.0 | 14.43.0composer require orchid/platform:^14.43.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for orchid/platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update orchid/platform to 14.43.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cm46-gqf4-mv4f is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-cm46-gqf4-mv4f in your dependencies?
Find it across Packagist, including transitive dependencies.