GHSA-chh6-ppwq-jh92 is a medium-severity (CVSS 5.7) CWE-281 vulnerability in github.com/etcd-io/etcd. A fix is available for github.com/etcd-io/etcd — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/etcd-io/etcd🐹github.com/etcd-io/etcdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Vulnerability type
Access Controls
Detail
etcd creates certain directory paths (etcd data directory and the directory path when provided to automatically generate self-signed certificates for TLS connections with clients) with restricted access permissions (700) by using the os.MkdirAll. This function does not perform any permission checks when a given directory path exists already.
Specific Go Package Affected
github.com/etcd-io/etcd/pkg/fileutil
Workarounds
Make sure these directories have the desired permit (700).
References
Find out more on this vulnerability in the security audit report
For more information
If you have any questions or comments about this advisory:
- Contact the etcd security committee
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/etcd-io/etcd | ≥ 3.4.0-rc.0&&< 3.4.10 | 3.4.10go get github.com/etcd-io/etcd@v3.4.10 |
| 🐹Go | github.com/etcd-io/etcd | all versions | 3.3.23go get github.com/etcd-io/etcd@v3.3.23 |
Affected Products
etcdetcdfedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/etcd-io/etcd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/etcd-io/etcd to 3.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-chh6-ppwq-jh92 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In Red Hat OpenShift Container Platform (RHOCP) the affected components are behind OpenShift OAuth authentication. This restricts access to the vulnerable etcd to authenticated users only, therefore the impact by this vulnerability is Low. A similar access restriction is in place in Red Hat OpenStack Platform (RHOSP)…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.8 | openshift4/ose-etcd:v4.8.0-202106152230.p0.git.aefa6bf.assembly.stream | RHSA-2021:2438 |
| Red Hat OpenStack Platform 16.1 | etcd-0:3.3.23-1.el8ost | RHSA-2021:0916 |
Frequently Asked Questions
Is GHSA-chh6-ppwq-jh92 in your dependencies?
Find it across Go, including transitive dependencies.