OpenClaw: Image Tool `tools.fs.workspaceOnly` Bypass via Sandbox Bridge MountsGHSA-cfp9-w5v9-3q4h
MEDIUMFix: openclaw/openclaw@14baaddGHSA-cfp9-w5v9-3q4h is a medium-severity (CVSS 6.5) CWE-668 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cfp9-w5v9-3q4h.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
The image tool did not fully honor the tools.fs.workspaceOnly filesystem boundary. In affected releases, image-path resolution could still traverse sandbox bridge mounts outside the workspace and read files from mounted directories that the other file tools would reject.
Affected Packages / Versions
- Package:
openclaw(npm) - Affected:
< 2026.3.2 - Fixed:
>= 2026.3.2 - Latest released tags checked:
v2026.3.23(ccfeecb6887cd97937e33a71877ad512741e82b2) andv2026.3.23-2(630f1479c44f78484dfa21bb407cbe6f171dac87) - Latest published npm version checked:
2026.3.23-2
Fix Commit(s)
dd9d9c1c609dcb4579f9e57bd7b5c879d0146b5314baadda2c456f3cf749f1f97e8678746a34a7f4
Release Status
The complete fix shipped in v2026.3.2 and remains present in v2026.3.23 and v2026.3.23-2.
Code-Level Confirmation
src/agents/openclaw-tools.tsnow passesfsPolicyintocreateImageTool, so the image tool receives the same workspace-only policy input as the other filesystem tools.src/agents/tools/image-tool.ts,src/agents/tools/media-tool-shared.ts, andsrc/agents/sandbox-media-paths.tsnow restrict local roots and sandbox-bridge resolution to the workspace whentools.fs.workspaceOnlyis enabled.
OpenClaw thanks @YLChen-007 for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.3.2npm install openclaw@2026.3.2 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cfp9-w5v9-3q4h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-cfp9-w5v9-3q4h in your dependencies?
Find it across npm, including transitive dependencies.