Pillow denial of service via Crafted Block SizeGHSA-cfmr-38g9-f2h7
HIGHFix: python-pillow/Pillow@205e056GHSA-cfmr-38g9-f2h7 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in pillow. A fix is available for pillow — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pillow🐍pillowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pillow | all versions | 2.3.2pip install --upgrade 'pillow==2.3.2' |
| 🐍PyPI | pillow | ≥ 2.5&&< 2.5.2 | 2.5.2pip install --upgrade 'pillow==2.5.2' |
Affected Products
python-imagingdebianopensuseopensusepillowpythonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pillow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pillow to 2.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cfmr-38g9-f2h7 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-cfmr-38g9-f2h7 in your dependencies?
Find it across PyPI, including transitive dependencies.