GHSA-cfgp-2977-2fmm is a high-severity (CVSS 7.4) CWE-440 vulnerability in io.grpc:grpc-protobuf. A fix is available for io.grpc:grpc-protobuf — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cfgp-2977-2fmm.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.grpc:grpc-protobuf☕io.grpc:grpc-protobuf🐍grpcio🐍grpcio💎grpc💎grpcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
When gRPC HTTP2 stack raised a header size exceeded error, it skipped parsing the rest of the HPACK frame. This caused any HPACK table mutations to also be skipped, resulting in a desynchronization of HPACK tables between sender and receiver. If leveraged, say, between a proxy and a backend, this could lead to requests from the proxy being interpreted as containing headers from different proxy clients - leading to an information leak that can be used for privilege escalation or data exfiltration. We recommend upgrading beyond the commit contained in https://github.com/grpc/grpc/pull/33005 https://github.com/grpc/grpc/pull/33005
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.grpc:grpc-protobuf | ≥ 1.53.0&&< 1.53.1 | 1.53.1io.grpc:grpc-protobuf:1.53.1 |
| ☕Maven | io.grpc:grpc-protobuf | ≥ 1.54.0&&< 1.54.2 | 1.54.2io.grpc:grpc-protobuf:1.54.2 |
| 🐍PyPI | grpcio | ≥ 1.53.0&&< 1.53.1 | 1.53.1pip install --upgrade 'grpcio==1.53.1' |
| 🐍PyPI | grpcio | ≥ 1.54.0&&< 1.54.2 | 1.54.2pip install --upgrade 'grpcio==1.54.2' |
| 💎RubyGems | grpc | ≥ 1.53.0&&< 1.53.1 | 1.53.1bundle update grpc --conservative |
| 💎RubyGems | grpc | ≥ 1.54.0&&< 1.54.2 | 1.54.2bundle update grpc --conservative |
Affected Products
grpcgrpcDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.grpc:grpc-protobuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.grpc:grpc-protobuf to 1.53.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cfgp-2977-2fmm is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 9 | rhc-worker-playbook-0:0.1.10-1.el9_5 | RHSA-2024:10761 |
Frequently Asked Questions
Is GHSA-cfgp-2977-2fmm in your dependencies?
Find it across Maven, PyPI, RubyGems, including transitive dependencies.