Envoy crashes when HTTP ext_proc processes local repliesGHSA-cf3q-gqg7-3fm9
MEDIUMFix: envoyproxy/envoy@8eda1b8GHSA-cf3q-gqg7-3fm9 is a medium-severity (CVSS 6.5) CWE-460 vulnerability in github.com/envoyproxy/envoy. A fix is available for github.com/envoyproxy/envoy — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cf3q-gqg7-3fm9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Envoy's ext_proc HTTP filter is at risk of crashing if a local reply is sent to the external server due to the filter's life time issue. A known situation is the fail of a websocket handshake will trigger a local reply leading to the crash of Envoy.
PoC
If both websocket and ext_proc are enabled, a failed handshake will trigger a local reply, thus ext_proc will crash.
Mitigation
- Disable websocket traffic
- Change the websocket response from backend to always return
101 Switch protocolbased on RFC. - Apply the patch and the ext_proc filter will not send the local reply that is generated by Envoy to the ext_proc server for processing.
- Apply the patch that the router will cancel the upstream requests when sending a local reply.
Impact
Denial of service
Reporter
Vasilios Syrakis Fernando Cainelli
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/envoyproxy/envoy | all versions | 1.30.10go get github.com/envoyproxy/envoy@v1.30.10 |
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.31.0&&< 1.31.6 | 1.31.6go get github.com/envoyproxy/envoy@v1.31.6 |
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.32.0&&< 1.32.4 | 1.32.4go get github.com/envoyproxy/envoy@v1.32.4 |
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.33.0&&< 1.33.1 | 1.33.1go get github.com/envoyproxy/envoy@v1.33.1 |
Affected Products
envoyenvoyproxyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/envoyproxy/envoy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/envoyproxy/envoy to 1.30.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cf3q-gqg7-3fm9 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-cf3q-gqg7-3fm9 in your dependencies?
Find it across Go, including transitive dependencies.