Magento Improper Authorization vulnerability in the customers moduleGHSA-cc3w-r3w8-hfh7
MEDIUMFix: magento/magento2@1bd5cb8GHSA-cc3w-r3w8-hfh7 is a medium-severity (CVSS 5) CWE-285 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/project-community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.4.0&&< 2.4.2-p1 | 2.4.2-p1composer require magento/community-edition:^2.4.2-p1 |
| 🐘Packagist | magento/community-edition | all versions | 2.3.7composer require magento/community-edition:^2.3.7 |
| 🐘Packagist | magento/project-community-edition | all versions | No fix |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.4.2-p1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cc3w-r3w8-hfh7 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-cc3w-r3w8-hfh7 in your dependencies?
Find it across Packagist, including transitive dependencies.