NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

Duplicate Advisory: ring has some AES functions that may panic when overflow checking is enabled inGHSA-c86p-w88r-qvqr

MEDIUMFix: briansmith/ring#2447

GHSA-c86p-w88r-qvqr is a medium-severity (CVSS 5.3) CWE-770 vulnerability in ring. A fix is available for ring — see the affected versions and patch details below.

Also known asCVE-2025-4432GHSA-4p46-pwfr-66x6GO-2025-3678RUSTSEC-2025-0009
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-c86p-w88r-qvqr.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.51%1.02%1.53%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀ring

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-4p46-pwfr-66x6. This link is maintained to preserve external references.

Original Description

A flaw was found in Rust's Ring package. A panic may be triggered when overflow checking is enabled. In the QUIC protocol, this flaw allows an attacker to induce this panic by sending a specially crafted packet. It will likely occur unintentionally in 1 out of every 2**32 packets sent or received.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioringall versions0.17.13cargo update -p ring --precise 0.17.13

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ring to 0.17.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c86p-w88r-qvqr is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-4p46-pwfr-66x6. This link is maintained to preserve external references. ### Original Description A flaw was found in Rust's Ring package. A panic may be triggered when overflow checking is enabled. In the QUIC protocol, this flaw allows an attacker to induce this panic by sending a specially crafted packet. It will likely occur unintentionally in 1 out of every 2**32 packets sent or received.
O3 Security · Impact-Aware SCA

Is GHSA-c86p-w88r-qvqr in your dependencies?

Find it across crates.io, including transitive dependencies.

GHSA-c86p-w88r-qvqr: ring — Fixed in 0.17.13