Apache Solr insecure inter-node communicationGHSA-c82r-qg3w-q5mv
HIGHGHSA-c82r-qg3w-q5mv is a high-severity (CVSS 7.5) Improper Authentication vulnerability in org.apache.solr:solr-core. A fix is available for org.apache.solr:solr-core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.solr:solr-core☕org.apache.solr:solr-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Solr uses a PKI based mechanism to secure inter-node communication when security is enabled. It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster. So, if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin or if the user has implemented a custom Authentication plugin, which does not implement either "HttpClientInterceptorPlugin" or "HttpClientBuilderPlugin", his/her servers are vulnerable to this attack. Users who only use SSL without basic authentication or those who use Kerberos are not affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.solr:solr-core | ≥ 5.3.0&&< 5.5.5 | 5.5.5org.apache.solr:solr-core:5.5.5 |
| ☕Maven | org.apache.solr:solr-core | ≥ 6.0.0&&< 6.6.0 | 6.6.0org.apache.solr:solr-core:6.6.0 |
Affected Products
solrapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.solr:solr-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.solr:solr-core to 5.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c82r-qg3w-q5mv is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-c82r-qg3w-q5mv in your dependencies?
Find it across Maven, including transitive dependencies.