NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Parse Server has a SQL injection via query field name when using PostgreSQLGHSA-c442-97qw-j6c6

GHSA-c442-97qw-j6c6 is a SQL Injection vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.

Also known asBIT-parse-2026-32234CVE-2026-32234
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-c442-97qw-j6c6.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

62other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-servernpm
59Kdownloads / week

Description

Impact

An attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level.

This vulnerability only affects Parse Server deployments using PostgreSQL.

Patches

The fix applies proper SQL identifier escaping to field names in the query handler and hardens query field name validation to reject malicious field names for all query types.

Workarounds

There is no known workaround.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-server≥ 9.0.0&&< 9.6.0-alpha.109.6.0-alpha.10npm install parse-server@9.6.0-alpha.10
📦npmparse-serverall versions8.6.36npm install parse-server@8.6.36

Affected Products

1 product · 11 configurations
Application
parse-serverparseplatform
≥ 9.0.0 && < 9.6.0
1 version
9.6.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-server to 9.6.0-alpha.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c442-97qw-j6c6 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Impact An attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a `$regex` query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using Po
O3 Security · Impact-Aware SCA

Is GHSA-c442-97qw-j6c6 in your dependencies?

Find it across npm, including transitive dependencies.

Parse Server has a SQL injection via query field name…