NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

OpenNMS Horizon RCE via JEXL2 expressionGHSA-c3mp-9vx3-2rvv

HIGHFix: OpenNMS/opennms#3281

GHSA-c3mp-9vx3-2rvv is a high-severity (CVSS 8.8) remote code execution vulnerability in org.opennms:opennms. A fix is available for org.opennms:opennms — see the affected versions and patch details below.

Also known asCVE-2021-3396
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.86%2.22%2.58%2.93%2.4%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.opennms:opennms☕org.opennms.features:org.opennms.features.measurements☕org.opennms:opennms-provision☕org.opennms:opennms-util

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.opennms:opennms≥ 16.0.0&&< 27.0.427.0.4org.opennms:opennms:27.0.4
☕Mavenorg.opennms.features:org.opennms.features.measurements≥ 16.0.0&&< 27.0.427.0.4org.opennms.features:org.opennms.features.measurements:27.0.4
☕Mavenorg.opennms:opennms-provision≥ 16.0.0&&< 27.0.427.0.4org.opennms:opennms-provision:27.0.4
☕Mavenorg.opennms:opennms-util≥ 16.0.0&&< 27.0.427.0.4org.opennms:opennms-util:27.0.4

Affected Products

3 products · 7 configurations
Application
horizonopennms
≥ 16.0.0 && ≤ 27.0.3
range
Application
meridianopennms
≥ 2020.1.0 && ≤ 2017.1.26
range
Application
newtsopennms
< 1.5.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opennms:opennms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.opennms:opennms to 27.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c3mp-9vx3-2rvv is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.
O3 Security · Impact-Aware SCA

Is GHSA-c3mp-9vx3-2rvv in your dependencies?

Find it across Maven, including transitive dependencies.

OpenNMS Horizon RCE via JEXL2 expression (High 8.8)