GHSA-c25x-cm9x-qqgx is a critical-severity (CVSS 9.9) Out-of-bounds Read vulnerability in Deno. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for Deno — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-c25x-cm9x-qqgx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Deno🦀serde_v8🦀deno_runtimeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Resizable ArrayBuffers passed to asynchronous native functions that are shrunk during the asynchronous operation could result in an out-of-bound read/write.
It is unlikely that this has been exploited in the wild, as the only version affected is Deno 1.32.0.
Deno Deploy users are not affected.
Patches
The problem has been resolved by disabling resizable ArrayBuffers temporarily in Deno 1.32.1. A future version of Deno will re-enable resizable ArrayBuffers with a proper fix.
Workarounds
Upgrade to Deno 1.32.1, or run with --v8-flags=--no-harmony-rab-gsab to disable resizable ArrayBuffers.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | Deno | ≥ 1.32.0&&< 1.32.1 | 1.32.1cargo update -p Deno --precise 1.32.1 |
| 🦀crates.io | serde_v8 | ≥ 0.87.0&&< 0.88.0 | 0.88.0cargo update -p serde_v8 --precise 0.88.0 |
| 🦀crates.io | deno_runtime | ≥ 0.102.0&&< 0.103.0 | 0.103.0cargo update -p deno_runtime --precise 0.103.0 |
Affected Products
denodenodeno runtimedenoserde v8denoResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Deno, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Deno to 1.32.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c25x-cm9x-qqgx is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-c25x-cm9x-qqgx in your dependencies?
Find it across crates.io, including transitive dependencies.