NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

Duplicate Advisory: Consensys gnark-crypto allows Signature MalleabilityGHSA-9xfq-8j3r-xp5g

CRITICALFix: Consensys/gnark-crypto#449

GHSA-9xfq-8j3r-xp5g is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in github.com/Consensys/gnark-crypto. A fix is available for github.com/Consensys/gnark-crypto — see the affected versions and patch details below.

Also known asCVE-2023-44273GHSA-fr8m-434r-g3xpGO-2023-2096GO-2025-4027
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9xfq-8j3r-xp5g.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/Consensys/gnark-crypto🐹github.com/consensys/gnark-crypto

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-fr8m-434r-g3xp. This link is maintained to preserve external references.

Original Description

Consensys gnark-crypto through 0.11.2 allows Signature Malleability. This occurs because deserialisation of EdDSA and ECDSA signatures does not ensure that the data is in a certain interval.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/Consensys/gnark-cryptoall versions0.12.0go get github.com/Consensys/gnark-crypto@v0.12.0
🐹Gogithub.com/consensys/gnark-cryptoall versions0.12.0go get github.com/consensys/gnark-crypto@v0.12.0

Affected Products

1 product · 1 configurations
Application
gnark-cryptoconsensys
< 0.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/Consensys/gnark-crypto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/Consensys/gnark-crypto to 0.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9xfq-8j3r-xp5g is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

## Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-fr8m-434r-g3xp. This link is maintained to preserve external references. ## Original Description Consensys gnark-crypto through 0.11.2 allows Signature Malleability. This occurs because deserialisation of EdDSA and ECDSA signatures does not ensure that the data is in a certain interval.
O3 Security · Impact-Aware SCA

Is GHSA-9xfq-8j3r-xp5g in your dependencies?

Find it across Go, including transitive dependencies.

Duplicate Advisory: Consensys gnark-crypto allows…