NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Svelte devalue: DoS via malformed inputGHSA-9rgm-9g3h-6x36

MEDIUMFix: sveltejs/devalue@8b2a456

GHSA-9rgm-9g3h-6x36 is a medium-severity (CVSS 5.3) CWE-770 vulnerability in devalue. A fix is available for devalue — see the affected versions and patch details below.

Also known asCVE-2026-81176
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9rgm-9g3h-6x36.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.01%0.34%0.67%1.01%0.5%0.5%0.5%Oct 26Nov 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

389other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
devaluenpm
24.5Mdownloads / week

Description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdevalueall versions5.9.2npm install devalue@5.9.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for devalue, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update devalue to 5.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9rgm-9g3h-6x36 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

A flaw was found in the Svelte devalue JavaScript library, which is bundled as a dependency in several Red Hat products. The devalue.parse function does not reject out-of-bounds array indices (indices greater than or equal to values.length), so a specially crafted untrusted payload can make the parser alternate…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for GHSA-9rgm-9g3h-6x36 (CC BY 4.0)

Frequently Asked Questions

### Impact `devalue.parse` prior to version 5.9.2 fails to reject out-of-bounds indices. Specially-crafted payloads can exploit this to cause devalue to alternate between different array representations, resulting in work that is quadratic with payload size. Applications are potentially affected if they call `devalue.parse` with untrusted data. ### Patches The bug is fixed in `[email protected]`.
O3 Security · Impact-Aware SCA

Is GHSA-9rgm-9g3h-6x36 in your dependencies?

Find it across npm, including transitive dependencies.

Svelte devalue: DoS via malformed input (Medium 5.3)