NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Denial-of-Service when binding invalid parameters in sqlite3GHSA-9qrh-qjmc-5w2p

HIGHFix: TryGhost/node-sqlite3@593c9d4

GHSA-9qrh-qjmc-5w2p is a high-severity (CVSS 7.5) vulnerability in sqlite3. A fix is available for sqlite3 — see the affected versions and patch details below.

Also known asCVE-2022-21227
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.93%1.87%2.80%0.3%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sqlite3npm
3.0Mdownloads / week

Description

Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of sqlite3 v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsqlite3≥ 5.0.0&&< 5.0.35.0.3npm install sqlite3@5.0.3

Affected Products

1 product · 1 configurations
Application
sqlite3ghost
< 5.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sqlite3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sqlite3 to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9qrh-qjmc-5w2p is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of `sqlite3` v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.
O3 Security · Impact-Aware SCA

Is GHSA-9qrh-qjmc-5w2p in your dependencies?

Find it across npm, including transitive dependencies.

Denial-of-Service when binding invalid parameters in sqlite3