lz4-sys vulnerable to memory corruption via issue in liblz4GHSA-9q5j-jm53-v7vr
CRITICALFix: lz4/lz4#972GHSA-9q5j-jm53-v7vr is a critical-severity (CVSS 9.8) remote code execution vulnerability in lz4-sys. A fix is available for lz4-sys — see the affected versions and patch details below.
Real-World Exposure
lz4-sysReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
lz4-sys up to v1.9.3 bundles a version of liblz4 that is vulnerable to CVE-2021-3520.
Attackers could craft a payload that triggers an integer overflow upon decompression, causing an out-of-bounds write.
The flaw has been corrected in version v1.9.4 of liblz4, which is included in lz4-sys 1.9.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | lz4-sys | all versions | 1.9.4cargo update -p lz4-sys --precise 1.9.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lz4-sys, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update lz4-sys to 1.9.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9q5j-jm53-v7vr is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-9q5j-jm53-v7vr in your dependencies?
Find it across crates.io, including transitive dependencies.