NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Unauthorized npm publish of [email protected] with modified postinstall scriptGHSA-9ppg-jx86-fqw7

GHSA-9ppg-jx86-fqw7 is a security vulnerability in cline. A fix is available for cline — see the affected versions and patch details below.

Also known asMAL-2026-1380
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 9, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

19other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
clinenpm
98Kdownloads / week

Description

Description

On February 17, 2026 at 3:26 AM PT, an unauthorized party used a compromised npm publish token to publish an update to Cline CLI on the NPM registry: [email protected]. The published package contains a modified package.json with an added postinstall script: "postinstall": "npm install -g openclaw@latest" This causes openclaw (an unrelated, non-malicious open source package) to be globally installed when [email protected] is installed. No other files were modified -- the CLI binary (dist/cli.mjs) and all other package contents are identical to the legitimate [email protected] release. A corrected version (2.4.0) was published at 11:23 AM PT and 2.3.0 was deprecated at 11:30 AM PT. The compromised token has been revoked and npm publishing now uses OIDC provenance via GitHub Actions.

Impact

Users who installed Cline CLI [email protected] during the approximately 8-hour window between 3:26 AM PT and 11:30 AM PT on February 17 will have openclaw globally installed. The openclaw package is a legitimate open source project and is not malicious, but its installation was not authorized or intended.

The Cline VS Code extension and JetBrains plugin were not affected. This advisory applies only to the Cline CLI package published on npm.

Patches

Versions 2.4.0 and higher are fixed

Workarounds

If you installed Cline CLI [email protected]:

  1. Update to the latest version of the Cline CLI cline update or npm installl -g cline@latest
  2. Verify that you have a fixed version (2.4.0 or higher) cline --version
  3. Review your environment for any unexpected installation of OpenClaw and remove it if not intended npm uninstall -g openclaw

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmcline≥ 2.3.0&&< 2.4.02.4.0npm install cline@2.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cline, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cline to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9ppg-jx86-fqw7 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Description On February 17, 2026 at 3:26 AM PT, an unauthorized party used a compromised npm publish token to publish an update to Cline CLI on the NPM registry: [email protected]. The published package contains a modified package.json with an added postinstall script: `"postinstall": "npm install -g openclaw@latest"` This causes openclaw (an unrelated, non-malicious open source package) to be globally installed when [email protected] is installed. No other files were modified -- the CLI binary (dist/cli.mjs) and all other package contents are identical to the legitimate [email protected] release. A correct
O3 Security · Impact-Aware SCA

Is GHSA-9ppg-jx86-fqw7 in your dependencies?

Find it across npm, including transitive dependencies.

Unauthorized npm publish of cline@2.3.0 with modified…