@clerk/backend Performs Insufficient Verification of Data AuthenticityGHSA-9mp4-77wg-rwx9
HIGHGHSA-9mp4-77wg-rwx9 is a high-severity (CVSS 7.5) CWE-345 vulnerability in @clerk/backend. A fix is available for @clerk/backend — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-9mp4-77wg-rwx9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@clerk/backendnpm@clerk/astronpm@clerk/expressnpmDescription
Impact
Applications that use the verifyWebhook() helper to verify incoming Clerk webhooks are susceptible to accepting improperly signed webhook events.
Patches
@clerk/backend: the helper has been patched as of2.4.0@clerk/astro: the helper has been patched as of2.10.2@clerk/express: the helper has been patched as of1.7.4@clerk/fastify: the helper has been patched as of2.4.4@clerk/nextjs: the helper has been patched as of6.23.3@clerk/nuxt: the helper has been patched as of1.7.5@clerk/react-router: the helper has been patched as of1.6.4@clerk/remix: the helper has been patched as of4.8.5@clerk/tanstack-react-start: the helper has been patched as of0.18.3
Resolution
The issue was resolved in @clerk/backend 2.4.0 by:
- Properly parsing the webhook request's signatures and comparing them against the signature generated from the received event
Workarounds
If unable to upgrade, developers can workaround this issue by verifying webhooks manually, per this documentation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @clerk/backend | ≥ 2.0.0&&< 2.4.0 | 2.4.0npm install @clerk/backend@2.4.0 |
| 📦npm | @clerk/astro | ≥ 2.9.0&&< 2.10.2 | 2.10.2npm install @clerk/astro@2.10.2 |
| 📦npm | @clerk/express | ≥ 1.6.0&&< 1.7.4 | 1.7.4npm install @clerk/express@1.7.4 |
| 📦npm | @clerk/fastify | ≥ 2.3.0&&< 2.4.4 | 2.4.4npm install @clerk/fastify@2.4.4 |
| 📦npm | @clerk/nextjs | ≥ 6.2.10&&< 6.23.3 | 6.23.3npm install @clerk/nextjs@6.23.3 |
| 📦npm | @clerk/nuxt | ≥ 1.7.0&&< 1.7.5 | 1.7.5npm install @clerk/nuxt@1.7.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @clerk/backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @clerk/backend to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9mp4-77wg-rwx9 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-9mp4-77wg-rwx9 in your dependencies?
Find it across npm, including transitive dependencies.