NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Stimulsoft Dashboard.JS Cross Site Scripting vulnerabilityGHSA-9m6m-c64r-w4f4

MEDIUM

GHSA-9m6m-c64r-w4f4 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in stimulsoft-dashboards-js. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for stimulsoft-dashboards-js — see the affected versions and patch details below.

Also known asCVE-2024-24396
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9m6m-c64r-w4f4.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.32%0.97%1.62%2.28%1.8%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
stimulsoft-dashboards-jsnpm
3Kdownloads / week

Description

Cross Site Scripting vulnerability in Stimulsoft GmbH Stimulsoft Dashboard.JS before v.2024.1.2 allows a remote attacker to execute arbitrary code via a crafted payload to the search bar component.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmstimulsoft-dashboards-jsall versions2024.1.2npm install stimulsoft-dashboards-js@2024.1.2

Affected Products

1 product · 1 configurations
Application
dashboard.jsstimulsoft
< 2024.1.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for stimulsoft-dashboards-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update stimulsoft-dashboards-js to 2024.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9m6m-c64r-w4f4 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Cross Site Scripting vulnerability in Stimulsoft GmbH Stimulsoft Dashboard.JS before v.2024.1.2 allows a remote attacker to execute arbitrary code via a crafted payload to the search bar component.
O3 Security · Impact-Aware SCA

Is GHSA-9m6m-c64r-w4f4 in your dependencies?

Find it across npm, including transitive dependencies.

Stimulsoft Dashboard.JS Cross Site Scripting vulnerability