NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

XWiki Platform vulnerable to page render failure due to broken translationsGHSA-9jq5-xwqw-q8j3

MEDIUM

GHSA-9jq5-xwqw-q8j3 is a medium-severity (CVSS 4.3) CWE-248 vulnerability in org.xwiki.platform:xwiki-platform-localization-source-wiki. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-localization-source-wiki — see the affected versions and patch details below.

Also known asCVE-2023-29520
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9jq5-xwqw-q8j3.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.34%0.68%1.03%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.xwiki.platform:xwiki-platform-localization-source-wiki☕org.xwiki.platform:xwiki-platform-localization-source-wiki☕org.xwiki.platform:xwiki-platform-localization-source-wiki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

It's possible to break many translations coming from wiki pages by creating a corrupted document containing a translation object.

Patches

The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11.

Workarounds

There is no other workaround other than fixing any way to create a document that fail to load.

References

https://jira.xwiki.org/browse/XWIKI-20460

For more information

If you have any questions or comments about this advisory:

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-localization-source-wiki≥ 4.3-milestone-2&&< 13.10.1113.10.11org.xwiki.platform:xwiki-platform-localization-source-wiki:13.10.11
☕Mavenorg.xwiki.platform:xwiki-platform-localization-source-wiki≥ 14.0-rc-1&&< 14.4.814.4.8org.xwiki.platform:xwiki-platform-localization-source-wiki:14.4.8
☕Mavenorg.xwiki.platform:xwiki-platform-localization-source-wiki≥ 14.5&&< 14.10.114.10.1org.xwiki.platform:xwiki-platform-localization-source-wiki:14.10.1

Affected Products

1 product · 3 configurations
Application
xwikixwiki
≥ 14.5 && < 14.10.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-localization-source-wiki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-localization-source-wiki to 13.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9jq5-xwqw-q8j3 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact It's possible to break many translations coming from wiki pages by creating a corrupted document containing a translation object. ### Patches The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11. ### Workarounds There is no other workaround other than fixing any way to create a document that fail to load. ### References https://jira.xwiki.org/browse/XWIKI-20460 ### For more information If you have any questions or comments about this advisory: * Open an issue in [Jira XWiki.org](https://jira.xwiki.org/) * Email us at [Security Mailing List](m
O3 Security · Impact-Aware SCA

Is GHSA-9jq5-xwqw-q8j3 in your dependencies?

Find it across Maven, including transitive dependencies.

XWiki Platform vulnerable to page render failure due to…