NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

BEdita vulnerable to SQL injectionGHSA-9gv2-2m38-j6cx

CRITICALFix: bedita/bedita#1608

GHSA-9gv2-2m38-j6cx is a critical-severity (CVSS 9.8) SQL Injection vulnerability in bedita/bedita. A fix is available for bedita/bedita — see the affected versions and patch details below.

Also known asCVE-2019-15570
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.65%1.30%1.95%0.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bedita/bedita

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

BEdita through 4.0.0-RC2 allows SQL injection during a save operation for a relation with parameters due to a lack of JSON escaping.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbedita/beditaall versions4.0.0composer require bedita/bedita:^4.0.0

Affected Products

1 product · 7 configurations
Application
beditabedita
≤ 3.8.0
1 version
4.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bedita/bedita, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bedita/bedita to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9gv2-2m38-j6cx is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

BEdita through 4.0.0-RC2 allows SQL injection during a save operation for a relation with parameters due to a lack of JSON escaping.
O3 Security · Impact-Aware SCA

Is GHSA-9gv2-2m38-j6cx in your dependencies?

Find it across Packagist, including transitive dependencies.

BEdita vulnerable to SQL injection (Critical 9.8)