NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntaxGHSA-9f58-4465-23c7

MEDIUMFix: code16/sharp#654

GHSA-9f58-4465-23c7 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in code16/sharp. A fix is available for code16/sharp — see the affected versions and patch details below.

Also known asCVE-2025-62798
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9f58-4465-23c7.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘code16/sharp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component.

In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed.

For example, if a field’s value contains {{ Math.random() }}, it will be executed instead of being displayed as text.

Impact

Attackers who can control content rendered through SharpShowTextField could execute arbitrary JavaScript in the context of an authenticated user’s browser.

This could lead to:

  • Theft of user session tokens.
  • Unauthorized actions performed on behalf of users.
  • Injection of malicious content into the admin panel.

Patches

The issue has been fixed in v9.11.1 of code16/sharp package.

Mitigation / Workarounds

Sanitize or encode any user-provided data that may include ({{ & }}) before displaying it in a SharpShowTextField.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcode16/sharpall versions9.11.1composer require code16/sharp:^9.11.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for code16/sharp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update code16/sharp to 9.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9f58-4465-23c7 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in `{{` & `}}` were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. For example, if a field’s value contains `{{ Math.random() }}`, it will be executed instead of being displayed as text. ### Impact Attackers who can control content rendered through SharpShowTextField could execute arbitrary JavaScript in the context of an au
O3 Security · Impact-Aware SCA

Is GHSA-9f58-4465-23c7 in your dependencies?

Find it across Packagist, including transitive dependencies.

Sharp user-provided input can be evaluated in a…